Microsoft® Office

Excel 2007

• Cell References
• Editing
• Formatting

Information Technology Services

IT Training and Communications
3694 West Pine Mall
Phone: (314) 977-4000 • Email: helpdesk@slu.edu
http://www.slu.edu/its/
# Table of Contents

**Editing a Worksheet** ................................................................................................................................................ 4  
Cutting, Copying, and Pasting Cells............................................................................................................................ 5  
Moving and Copying Cells Using the Mouse................................................................................................................ 7  
Using the Office Clipboard........................................................................................................................................ 8  
Using the Paste Special Command............................................................................................................................ 9  
Checking Your Spelling........................................................................................................................................... 10  
Inserting Cells, Rows, and Columns ......................................................................................................................... 12  
Deleting Cells, Rows, and Columns............................................................................................................................ 13  
Using Find and Replace............................................................................................................................................ 14  
Using Cell Comments.............................................................................................................................................. 16

**Formatting a Worksheet** ....................................................................................................................................... 19  
Formatting Labels....................................................................................................................................................... 20  
Formatting Values...................................................................................................................................................... 21  
Working with Cell Alignment................................................................................................................................. 22  
Adding Cell Borders, Background Colors and Patterns ........................................................................................... 23  
Using the Format Painter......................................................................................................................................... 25  
Using Cell Styles....................................................................................................................................................... 26  
Using Document Themes......................................................................................................................................... 28  
Applying Conditional Formatting............................................................................................................................ 30  
Creating and Managing Conditional Formatting Rules ............................................................................................ 32  
Finding and Replacing Formatting .......................................................................................................................... 34

**Microsoft Office Excel 2007: Level 2 Review** ...................................................................................................... 36

Index........................................................................................................................................................................... 38
Editing a Worksheet

Cutting, Copying, and Pasting Cells .................... 5
Moving and Copying Cells Using the Mouse... 7
Using the Office Clipboard ............................... 8
Using the Paste Special Command .................. 9
Checking Your Spelling ....................................... 10
Inserting Cells, Rows, and Columns ................. 12
Deleting Cells, Rows, and Columns .................. 13
Using Find and Replace ...................................... 14
Using Cell Comments ........................................ 16

Insert a comment ................................................
View a comment ..................................................
Edit a comment .................................................. 
Delete a comment ................................................

This chapter will show you how to edit your Excel worksheets. You'll learn how to edit cell contents; cut, copy and paste information; insert and delete columns and rows; and even correct your spelling errors.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways you may follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that you may “build upon them,” which means that the exercises in a chapter can be performed in succession from the first lesson to the last.
Cutting, Copying, and Pasting Cells

You can move information around in an Excel worksheet by cutting or copying and then pasting the cell data in a new place. You can work with one cell at a time or ranges of cells.

Tips

✓ You may cut, copy, and paste any item in a worksheet, such as clip art or a picture—not just cell data.

Cut cells

When you cut a cell, it is removed from its original location and placed in a temporary storage area called the Clipboard.

1. Select the cell(s) you want to cut.
   Tip: If you want to cut or copy only selected parts of a cell’s contents, double-click the cell to display a cursor and select the characters you want to cut.

2. Click the Home tab on the Ribbon and click the Cut button in the Clipboard group.
   A moving dashed border appears around the cell(s).

   Other Ways to Cut Cells:
   Press <Ctrl> + <X>. Or, right-click the selection and select Cut from the contextual menu.

Copy cells

When you copy a cell, the selected cell data remains in its original location and is added to the Clipboard.

1. Select the cell(s) you want to copy.

2. Click the Home tab on the Ribbon and click the Copy button in the Clipboard group.

   Other Ways to Copy Cells:
   Press <Ctrl> + <C>. Or, right-click the selection and select Copy from the contextual menu.

Exercise Notes

• Exercise File: Sales3-2.xlsx
• Exercise: Open the Sales3-2 workbook and save it as Sales and Expenses. Copy cell A11 and paste it in cell A13. Then cut cell A6 and paste it over the contents in cell A11.

Figure 1-1: Copying and pasting a cell.
Paste cells

After cutting or copying, select a new cell and paste the item that you last cut or copied into the worksheet.

1. Click where you want to paste the cut or copied cell(s).
   
   ✓ Tip: If you’re pasting a cell range, click the cell where you want the upper-left corner of the pasted range to start.

2. Click the Home tab on the Ribbon and click the Paste button in the Clipboard group.
   The cut or copied cell data is pasted in the new location.

Other Ways to Paste Cells:
Press $<$Ctrl$>+<V$>. Or, right-click where you want to paste and select Paste from the contextual menu.

Tips

✓ After pasting, a Paste Options Smart Tag may appear. Click this button to specify how information is pasted into your worksheet.

✓ You may specify what you want to paste by using the Paste Special command. Click the Paste button list arrow in the Clipboard group and select Paste Special from the list. Choose a paste option in the Paste Special dialog box.

✓ To collect and paste multiple items, use the Office Clipboard.
Moving and Copying Cells Using the Mouse

Using the mouse to move and copy cells is even faster and more convenient than using the cut, copy and paste commands.

1. Select the cell(s) you want to move.
2. Point to the border of the cell or cell range.
3. Click and hold down the left-mouse button.
4. Drag the pointer to where you want to move the selected cell(s) and then release the mouse button.

Tips

✓ Press and hold the <Ctrl> key while clicking and dragging to copy the selection.

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Select cell range A7:G11. Move the cell range A7:G11 up one row.
Using the Office Clipboard

If you do a lot of cutting, copying, and pasting you will appreciate the **Office Clipboard**, which collects and pastes multiple items from Excel and other Office programs.

1. Click the **Home tab** on the **Ribbon** and click the **Dialog Box Launcher** located on the **Clipboard group**.
   
The Clipboard task pane appears along the left side of the window.

2. Cut and copy items as you normally would.
   
The Clipboard can hold 24 items at a time.

3. Click where you want to paste an item from the **Clipboard**.

4. Click the item in the **Clipboard**.

**Tips**

- While the Clipboard is displayed, each cut or copied item is saved to the Clipboard. If the Clipboard is not displayed, the last cut or copied item is replaced by the next one.
- As long as the **Clipboard** is open, it collects items that are cut or copied from all Office programs.
- To remove an item from the **Clipboard**, click the item’s list arrow and select **Delete**. Click the **Clear All button** in the task pane to remove all items from the **Clipboard**.
- Click the **Options button** near the bottom of the **task pane** to control how the Clipboard operates.
Using the Paste Special Command

Excel’s Paste Special command lets you specify exactly what you want to copy and paste. For example, you can use the Paste Special command to paste the resulting value of a formula without pasting the formula itself, or to paste the values of a range of cells without any of the cells’ formatting options.

1. Copy an item as you normally would.
2. Click the cell where you want to paste the item.
3. Click the Home tab and click the arrow of the Paste button located in the Clipboard group. Select Paste Special.
   The Paste Special dialog box appears.

4. Click a paste option, and then click the OK button.
5. Double-click away from the cell to deselect the copied cell and confirm the paste.

Other Ways to Paste Special:
Copy and paste as you normally would. Click the Paste Options Smart Tag that appears next to the pasted item and select a paste option from the list.

Table 1-1: Paste Special Options

<table>
<thead>
<tr>
<th>Paste Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Pastes all cell contents and formatting. Same as the Paste command.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Pastes only the formulas as entered in the formula bar.</td>
</tr>
<tr>
<td>Values</td>
<td>Pastes only the values as displayed in the cells.</td>
</tr>
<tr>
<td>Formats</td>
<td>Pastes only cell formatting. Same as using the Format Painter button.</td>
</tr>
<tr>
<td>Comments</td>
<td>Pastes only comments attached to the cell.</td>
</tr>
<tr>
<td>Validation</td>
<td>Pastes data validation rules for the copied cells to the paste area.</td>
</tr>
<tr>
<td>All using Source theme</td>
<td>Pastes all cell contents and formatting, including the theme, if one was applied to the source data.</td>
</tr>
<tr>
<td>All except borders</td>
<td>Pastes all cell contents and formatting applied to the copied cell except borders.</td>
</tr>
<tr>
<td>Column widths</td>
<td>Pastes only the width of the source cell’s column to the destination cell’s column.</td>
</tr>
<tr>
<td>Formulas and number formats</td>
<td>Pastes only the formulas and number formats.</td>
</tr>
<tr>
<td>Values and number formats</td>
<td>Pastes only the values and number formats.</td>
</tr>
<tr>
<td>Operation (several options)</td>
<td>Specifies which mathematical operation, if any, you want to apply to the copied data. For example, you could multiply the pasted data by 5.</td>
</tr>
<tr>
<td>Skip blanks</td>
<td>Avoids replacing values in your paste area when blank cells occur in the copy area.</td>
</tr>
<tr>
<td>Transpose</td>
<td>Changes columns of copied data to rows, and vice versa.</td>
</tr>
<tr>
<td>Paste Link</td>
<td>Links the pasted data to the source data by pasting a formula reference to the source data.</td>
</tr>
</tbody>
</table>

Figure 1-5: The Paste Special dialog box.

Exercise Notes

- Exercise File: Sales3-5.xlsx
- Exercise: Copy the cell range G4:G9. Using the Paste Special command, paste “values” in the same range you copied, so that the formulas in cells G4:G9 are replaced by values only.

1. Copy an item as you normally would.
2. Click the cell where you want to paste the item.
3. Click the Home tab and click the arrow of the Paste button located in the Clipboard group. Select Paste Special.
   The Paste Special dialog box appears.

4. Click a paste option, and then click the OK button.
5. Double-click away from the cell to deselect the copied cell and confirm the paste.

Other Ways to Paste Special:
Copy and paste as you normally would. Click the Paste Options Smart Tag that appears next to the pasted item and select a paste option from the list.

Table 1-1: Paste Special Options

<table>
<thead>
<tr>
<th>Paste Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Pastes all cell contents and formatting. Same as the Paste command.</td>
</tr>
<tr>
<td>Formulas</td>
<td>Pastes only the formulas as entered in the formula bar.</td>
</tr>
<tr>
<td>Values</td>
<td>Pastes only the values as displayed in the cells.</td>
</tr>
<tr>
<td>Formats</td>
<td>Pastes only cell formatting. Same as using the Format Painter button.</td>
</tr>
<tr>
<td>Comments</td>
<td>Pastes only comments attached to the cell.</td>
</tr>
<tr>
<td>Validation</td>
<td>Pastes data validation rules for the copied cells to the paste area.</td>
</tr>
<tr>
<td>All using Source theme</td>
<td>Pastes all cell contents and formatting, including the theme, if one was applied to the source data.</td>
</tr>
<tr>
<td>All except borders</td>
<td>Pastes all cell contents and formatting applied to the copied cell except borders.</td>
</tr>
<tr>
<td>Column widths</td>
<td>Pastes only the width of the source cell’s column to the destination cell’s column.</td>
</tr>
<tr>
<td>Formulas and number formats</td>
<td>Pastes only the formulas and number formats.</td>
</tr>
<tr>
<td>Values and number formats</td>
<td>Pastes only the values and number formats.</td>
</tr>
<tr>
<td>Operation (several options)</td>
<td>Specifies which mathematical operation, if any, you want to apply to the copied data. For example, you could multiply the pasted data by 5.</td>
</tr>
<tr>
<td>Skip blanks</td>
<td>Avoids replacing values in your paste area when blank cells occur in the copy area.</td>
</tr>
<tr>
<td>Transpose</td>
<td>Changes columns of copied data to rows, and vice versa.</td>
</tr>
<tr>
<td>Paste Link</td>
<td>Links the pasted data to the source data by pasting a formula reference to the source data.</td>
</tr>
</tbody>
</table>
Checking Your Spelling

You can use Excel’s spell checker to find and correct spelling errors in your worksheets. To check the spelling of a worksheet all at once, use the Spelling dialog box.

1. Click the Review tab on the Ribbon and click the Spelling button in the Proofing group.

Excel begins checking spelling with the active cell.

Tip: Depending on which cell is active when you start the spell check, you may see a dialog box that asks you if you want to start your spell check from the beginning of the sheet. Select Yes.

Other Ways to Check Spelling:
Press <F7>.

If Excel finds an error, the Spelling dialog box appears with the misspelling in the “Not in Dictionary” text box. You have several options to choose from when the Spelling dialog box opens:

- **Ignore Once**: Accepts the spelling and moves on to the next spelling error.
- **Ignore All**: Accepts the spelling and ignores all future occurrences of the word in the worksheet.
- **Add to Dictionary**: If a word is not recognized in the Microsoft Office Dictionary, it is marked as misspelled. This command adds the word to the dictionary so it is recognized in the future.
- **Change**: Changes the spelling of the word to the spelling that is selected in the Suggestions list.
- **Change All**: Changes all occurrences of the word in the worksheet to the selected spelling.

Tip: Exercise caution when using this command—you might end up changing something you didn’t want to change.

- **AutoCorrect**: Changes the spelling of the word to the spelling that is selected in the Suggestions list, and adds the misspelled word to the AutoCorrect list so that Excel will automatically fix it whenever you type it in the future.

Exercise Notes

Exercise File: Sales and Expenses

Exercise: Delete the contents of cells G1:G3. Type “Jne” (June spelled incorrectly) in cell G3. Type “Net Inc.” in cell A12. Click cell B12 enter the formula =B4-B10. Copy cell B12 and paste formulas to cells C12:G12.

Run the spell check and correct spelling for the entire worksheet.
2. If the word is spelled incorrectly, select the correct spelling from the Suggestions list. Then click
   Change, Change All, or AutoCorrect. If the word is spelled correctly, click Ignore Once, Ignore All,
   Add to Dictionary.

   Excel applies the command and moves on to the next misspelling.

   Once Excel has finished checking your worksheet for spelling errors, a dialog box appears, telling you the
   spelling check is complete.

3. Click the OK button.

   The dialog box closes.

Tips

☑ Excel cannot catch spelling errors that occur because of misuse. For example, if you entered the word
   “through” when you meant to type “threw,” Excel wouldn’t catch it because “through” is a correctly
   spelled word.

☑ The AutoCorrect feature automatically corrects commonly misspelled words for you as you type.
Inserting Cells, Rows, and Columns

While working on a worksheet, you may need to insert new cells, columns, or rows. When you insert cells, the existing cells shift to make room for the new cells.

Insert cells

1. Select the cell or cell range where you want to insert cells.
   The number of cells you select is the number of cells to be inserted.
2. Click the Home tab located on the Ribbon. Click the arrow of the Insert button located in the Cells group. Select Insert Cells.
   The Insert dialog box appears. Here you can tell Excel how you want to move the existing cells to make room for the new ones by selecting “Shift cells right” or “Shift cells down.”
   ✅ Tip: You can also select “Entire row” or “Entire column” in the Insert dialog box to insert an entire row or column and not just a cell or cells.
3. Select the insert option you want to use and then click the OK button.
   The cell(s) are inserted and the existing cells shift.

Other Ways to Insert Cells:
Select the cell(s) where you want to insert cells, then right-click the cell(s) and select Insert from the contextual menu. Select an insert option and click OK.

Insert rows or columns

1. Select the row or column heading below or to the right of where you want to insert the row or column.
   The number of row or column headings you select is the number of rows or columns to be inserted.
2. Click the Home tab located on the Ribbon. Click the arrow of the Insert button located in the Cells group. Select Insert Rows or Insert Columns.
   The row or column is inserted. Existing rows are shifted downward, while existing columns are shifted to the right.

Other Ways to Insert Rows or Columns:
Right-click a row or column heading and select Insert from the contextual menu.

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Select cell A1, insert a new cell and shift the existing cells to the right. Insert a new row between rows 9 and 10.

Figure 1-7: Inserting a cell in a worksheet.

Figure 1-8: The Insert dialog box.
Deleting Cells, Rows, and Columns

You can quickly delete existing cells, columns, or rows from a worksheet. When you delete cells the existing cells shift to fill the space left by the deletion.

Delete cells

1. Select the cell(s) you want to delete.

2. Click the Home tab on the Ribbon. Click the arrow of the Delete button located on the Cells group. Click Delete Cells.

   The Delete dialog box appears. Here you can tell Excel how you want to move the remaining cells to cover the hole left by the deleted cell(s) by selecting “Shift cells left” or “Shift cells up.”

   ✔ Tip: You can also select Entire row or Entire column in the Delete dialog box to delete an entire row or column.

3. Select an option and then click the OK button.

   The cell(s) are deleted and the remaining cells are shifted.

   🔄 Trap: Pressing the <Delete> key only clears a cell’s contents, it doesn’t delete the actual cell.

   🔄 Other Ways to Delete Cells:
   Right-click the selection and select Delete from the contextual menu. Select an option and click OK.

Delete rows or columns

1. Select the row or column heading(s) you want to delete.

2. Click the Home tab on the Ribbon and click the Delete list arrow in the Cells group.

   The rows or columns are deleted. Remaining rows are shifted up, while remaining columns are shifted to the left.

   🔄 Other Ways to Delete Rows or Columns:
   Select the column or row heading(s) you want to delete, right-click any of them, and select Delete from the contextual menu.

Exercise Notes

• Exercise File: Sales and Expenses
• Exercise: Delete cell A1 and shift cells to the left. Delete row 10.
Using Find and Replace

Don’t waste time scanning your worksheet for labels and values that you want to replace with something new: Excel’s find and replace commands can do this for you with just a few clicks of your mouse.

Find

The Find feature makes it very easy to find specific words and values in a worksheet.

1. Click the Home tab located on the Ribbon. Click the Find & Select button located in the Editing group. Select Find from the list.

   The Find tab of the Find and Replace dialog box appears.

   Other Ways to Find Text:
   Press <Ctrl> + <F>.

2. Type the text or value you want to find in the “Find what” text box.

3. Click the Find Next button.

   Excel jumps to the first occurrence of the word, phrase, or value that you entered.

4. Click the Find Next button again to move on to other occurrences. When you’re finished, click Close.

Replace

Replace finds specific words and values, and then replaces them with something else.

1. Click the Home tab located on the Ribbon. Click the Find & Select button in the Editing group. Select Replace from the list.

   The Replace tab of the Find and Replace dialog box appears.

   Other Ways to Replace Text:
   Press <Ctrl> + <H>.

2. Type the text or value you want replace in the “Find what” text box.

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Use the Replace feature to find and replace all instances of “Sales” with “Income” in the worksheet.

Figure 1-10: The Find tab of the Find and Replace dialog box.

Figure 1-11: The Replace tab of the Find and Replace dialog box.
3. Type the replacement text or value in the “Replace with” text box.

4. Click the Find Next button.

   Excel jumps to the first occurrence of the word, phrase, or value in the “Find what” box.

5. Click Replace to replace the occurrence.

   Excel replaces the text or value and moves on to the next occurrence.

   Tip: Click Replace All to replace all occurrences in the worksheet without seeing them first.

6. When you’re finished, click the Close button.
Using Cell Comments

Sometimes you may need to add notes to a workbook to document complicated formulas or questionable values, or to leave a comment for another user. Excel’s **cell comments** command helps you document your worksheets and make them easier to understand. Think of cell comments as Post-It Notes that you can attach to any cell. Cell comments appear whenever you point at the cell they’re attached to.

**Insert a comment**

1. Click the cell you want to attach a comment to.
2. Click the **Review tab** located on the **Ribbon**. Click the **New Comment button** located in the **Comments group**.
3. Type a comment.
4. Click outside the comment area when you’re finished.

**Other Ways to Insert a Comment:**
Right-click the cell you want to attach a comment to and select **New Comment** from the contextual menu. Type a comment.

**View a comment**

- Point to the triangle-shaped comment marker that’s located in the cell with the comment.

**Tip:** To display a comment all the time, click the cell with the comment, then click the **Review tab** on the Ribbon and click the **Show/Hide Comments button** in the Comments group. Or, click the **Show All Comments button** in the Comments group to display all the comments in a worksheet at once.

**Edit a comment**

1. Click the cell that contains the comment you want to edit.
2. Click the **Review tab** located on the **Ribbon**. Click the **Edit Comment button** in the **Comments group**.
3. Edit the comment.

You can change the size of a comment text box by clicking and dragging one of the eight sizing handles that surrounds the comment.
4. Click outside the comment area when you’re finished.

⚠️ **Other Ways to Edit a Comment:**
Right-click the cell with the comment you want to edit and select **Edit Comment** from the contextual menu. Edit the comment.

**Delete a comment**

1. Click the cell that contains the comment you want to delete.

2. Click the **Review tab** located on the **Ribbon**. Click the **Delete button** in the **Comments group**.

⚠️ **Other Ways to Delete a Comment:**
Right-click the cell you want to delete and select **Delete Comment** from the contextual menu.
You probably have a few colleagues that dazzle everyone at meetings with their sharp-looking worksheets that use colorful fonts and borders.

This chapter explains how to format a worksheet to make it more visually attractive and easier to read.

You will learn how to change the appearance, size, and color of text and how to align text inside a cell. You will learn how to add borders and shading and how to use cell styles, as well as many other tools that will help your worksheets look more organized and professional.

Using Exercise Files
This chapter suggests exercises to practice the topic of each lesson. There are two ways you may follow along with the exercise files:

- Open the exercise file for a lesson, perform the lesson exercise, and close the exercise file.
- Open the exercise file for a lesson, perform the lesson exercise, and keep the file open to perform the remaining lesson exercises for the chapter.

The exercises are written so that you may “build upon them”, meaning the exercises in a chapter can be performed in succession from the first lesson to the last.
Formatting a Worksheet

Formatting Labels

You can emphasize text in a worksheet by making the text darker and heavier (bold), slanted (italics), or in a different typeface (font). The Font group on the Home tab makes it easy to apply character formatting.

1. Click the cell(s) with the label you want to format.

2. Click the Home tab located on the Ribbon. Click a formatting button in the Font group.

The label text is formatted.

Other Ways to Format Labels:

Right-click the cell(s) you want to format. Click a formatting button on the Mini Toolbar. Or, right-click the cell(s) you want to format and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Font group. Select formatting options on the Font tab in the Format Cells dialog box.

Tips

✓ To use different font formats for different characters within the same cell, select the cell, then in the Formula Bar select the portion of the text you want to format. Or, double-click the cell and select the portion of the text you want to format within the cell.

✓ The formatting buttons in the Font group, such as Font Color and Font Size, are not just for formatting labels—you can use them to format values as well.

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Format cell A1 with 14 pt Cambria font.

Format cell ranges B3:G3 and A4:A12 with bold Cambria font.

![Figure 2-1: The Format Cells dialog box](image)

Table 2-1: Font Formatting Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Make text darker and heavier.</td>
</tr>
<tr>
<td>Bold</td>
<td>Make text slant.</td>
</tr>
<tr>
<td>I</td>
<td>Make text slant.</td>
</tr>
<tr>
<td>Italic</td>
<td>Make text slant.</td>
</tr>
<tr>
<td>Underline list arrow</td>
<td>Add a line or double line under text.</td>
</tr>
<tr>
<td>Calibri</td>
<td>Select a different font.</td>
</tr>
<tr>
<td>Font list arrow</td>
<td>Adjust font size.</td>
</tr>
<tr>
<td>Font Size list arrow</td>
<td>Adjust font size by one increment.</td>
</tr>
<tr>
<td>Increase/Decrease Font Size</td>
<td>Adjust text color.</td>
</tr>
</tbody>
</table>

Table 2-1: Font Formatting Buttons
Formatting Values

Applying number formatting changes how values are displayed—it doesn’t change the actual information. Excel is often smart enough to apply some number formatting automatically. For example, if you use a dollar sign to indicate currency, such as $548.67, Excel will automatically apply the currency number format for you.

1. Click the cell(s) with the value(s) you want to format.

2. Click the Home tab located on the Ribbon. Click a formatting button in the Number Group.

The values are formatted.

Other Ways to Format Values:
Right-click the cell(s) you want to format. Click a formatting button on the Mini Toolbar. Or, right-click the cell(s) you want to format and select Format Cells from the contextual menu or click the Number group’s Dialog Box Launcher. Select formatting options on the Number tab in the Format Cells dialog box.

Tips
✓ Create custom number formats in the Format Cells dialog box by selecting the Custom category, selecting a number format code in the list, and editing it in the Type text box. Watch the sample area to see how the custom number format you create will be displayed.
✓ The formatting buttons in the Font group, such as Font Color and Font Size, are not just for formatting labels—you can use them to format values as well.
Working with Cell Alignment

By default, the contents of a cell appear at the bottom of the cell, with values (numbers) aligned to the right and labels (text) aligned to the left. This lesson explains how to control how data is aligned in a cell.

1. Select the cell(s) you want to align.

2. Click the Home tab on the Ribbon. Click an alignment button located in the Alignment group. The cell contents are realigned.

Other Ways to Align Cells:
Right-click the cell(s) you want to align. Click an alignment button on the Mini Toolbar. Or, right-click the cell(s) you want to align and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Alignment group. Select alignment options on the Alignment tab in the Format Cells dialog box.

Table 2-3: Cell Alignment Buttons in the Alignment Group

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Top/Middle/Bottom Align" /></td>
<td>Align cell contents to the top, middle, or bottom of the cell using these three buttons.</td>
</tr>
<tr>
<td><img src="image" alt="Align Left/Center/Right" /></td>
<td>Align cell contents to the left side, center, or right side of the cell using these three buttons.</td>
</tr>
<tr>
<td><img src="image" alt="Orientation" /></td>
<td>Align cell contents diagonally or vertically.</td>
</tr>
<tr>
<td><img src="image" alt="Decrease/Increase Indent" /></td>
<td>Increase or decrease the margin between the cell contents and the cell border with these two buttons.</td>
</tr>
<tr>
<td><img src="image" alt="Wrap Text" /></td>
<td>Make all cell contents visible by displaying them on multiple lines within the cell (this increases the row’s height).</td>
</tr>
<tr>
<td><img src="image" alt="Merge &amp; Center list arrow" /></td>
<td>Select from a few options for merging cells together and centering cell contents within the merged cells.</td>
</tr>
</tbody>
</table>

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Select cells B3:G3 and click the Center button located in the Alignment group.

Select cells A1:G1. Click the Merge and Center button located in the Alignment group.

Figure 2-3: The Format Cells dialog box with the Alignment tab displayed.

Formatting a Worksheet
Adding Cell Borders, Background Colors and Patterns

Adding cell borders and filling cells with colors and patterns can make them more attractive, organized and easy to read.

Add a cell border

Borders are lines that you can add to the top, bottom, left, or right of cells.

1. Select the cell(s) you want to add the border to.
2. Click the Home tab on the Ribbon. Click the arrow on the Border button located in the Font group.

A list of borders you can add to the selected cell(s) appears. Use the examples shown next to each border option to guide your decision.

If the border configuration you want doesn’t appear in the list, add one border at a time.

3. Select a border type.

The border is applied.

Tip: To remove a border, click the arrow on the Border button located in the Font group and select No Border.

Notice that the border option you chose now appears as the selected border type on the Border button. If you want to apply the same border to another cell, just click the Border button.

Other Ways to Add a Border:

Right-click the cell(s) you want to add the border to. Click the arrow on the Border button located on the Mini Toolbar and select a border. Or, right-click the cell(s) you want to format and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Font group.

Click the Border tab in the Format Cells dialog box and select border options.

Exercise Notes

- Exercise File: Sales and Expenses
- Exercise: Add a bottom border to cells B3:G3 and B9:G9.

Click cell A1 and add a light blue fill color (Accent 1, Lighter 80%) to the merged cell. Also, apply the 6.25% Gray pattern style (leave the Pattern Color as Automatic).
Add a cell background color
Fill the background of a cell by adding a color or pattern.

1. Select the cell(s) you want to add the color to.

2. Click the Home tab located on the Ribbon. Click the Fill Color list arrow in the Font group.
   A list of colors you can add to the selected cell(s) appears.

3. Select the color you want to use.
   The fill color is applied.

   Notice that the color you chose now appears as the selected color on the button. If you want to apply the shading to another paragraph, just click the button to apply the displayed shading color.

   Other Ways to Apply Background Color:
   Right-click the cell selection and click the Fill Color list arrow on the Mini Toolbar. Select a color. Or, right-click the cell(s) you want to format and select Format Cells from the contextual menu or click the Dialog Box Launcher in the Font group. Click the Fill tab in the Format Cells dialog box and select a background color or fill effects.

Add a cell background pattern

1. Right-click the selected cell(s) and select Format Cells from the contextual menu.
   The Format Cells dialog box appears.

   Other Ways to Display the Format Cells Dialog Box:
   Click the Home tab on the Ribbon and click the Format list arrow in the Cells group. Select Cells.

2. Click the Fill tab.

3. Click the Pattern Color list arrow and select a pattern color.

4. Click the Pattern Style list arrow and select a pattern style.

5. Click the OK button.

Tips
✓ You can use an image as the background of a worksheet. Click the Page Layout tab and click the Background button. Browse to and select the image you want to use as the worksheet background. Click Insert.

Figure 2-6: Selecting a pattern style on the Fill tab in the Format Cells dialog box.
Using the Format Painter

If you find yourself applying the same cell formatting again and again, then you should familiarize yourself with the Format Painter tool. The **Format Painter** allows you to copy the formatting of a cell or cell range and apply it elsewhere.

1. Select the cell(s) with the formatting you want to copy.

2. Click the **Home** tab on the **Ribbon**. Click the **Format Painter** button in the **Clipboard group**.

   **Other Ways to Access the Format Painter Button:**
   Select the cell(s) with the formatting options you want to copy, then right-click the selection. Click the **Format Painter** button on the Mini Toolbar.

   The mouse pointer changes to indicate it is ready to apply the copied formatting.

   **Tip:** Single-click the **Format Painter** button to apply copied formatting once. Double-click the **Format Painter** button to apply copied formatting as many times as necessary, then click it again or press the `<Esc>` key to deactivate the Format Painter.

3. Click the cell to which you want to apply the copied formatting.

   The copied formatting is applied.

---

**Exercise**

- **Exercise File:** Sales and Expenses
- **Exercise:** Click cell B3 and use the **Format Painter** to copy the bottom border formatting and apply it to the range B9:G10.

**Figure 2-7:** Using the Format Painter tool to copy formatting from cells in row 9 to cells in row 10.
Using Cell Styles

Cell Styles are preset formatting that can be applied to a cell or cell range, such as font name and size, borders and/or cell shading. Excel contains several preset styles for you to use.

You can also modify Excel’s preset cell styles, create new styles by duplicating and modifying the preset styles, or create completely new custom styles.

Apply a cell style

1. Select the cell(s) you want to format.
2. Click the Home tab. Click the Cell Styles button in the Styles group.
   A gallery of styles appears.
3. Select a cell style.
   Tip: Hover the pointer over a style to preview how it will look before selecting it.

Remove a cell style

1. Select the cell(s) that have the cell style applied.
2. Click the Home tab. Click the Cell Styles button in the Styles group.
3. Click the Normal style.
   Tip: These steps only remove the cell style from the selected cells—the cell style itself is not deleted from Excel. To remove a cell style from all cells and delete the cell style itself, click the Home tab on the Ribbon and click the Cell Styles button in the Styles group. Right-click the style you want to delete and select Delete.

Modify or duplicate a cell style

1. Click the Home tab. Click the Cell Styles button in the Styles group.
2. Right-click the cell style you want to modify and select Modify or Duplicate.
   Trap: Selecting Modify changes the built-in Excel style, while selecting Duplicate adds a new custom style and leaves the original built-in style alone.

Exercise

• Exercise File: Sales and Expenses
• Exercise: Select cell A1 and cell range A4:A12 and apply the “20% - Accent4” cell style to the cells.

Next, remove the cell style from the range A4:A12.
Duplicate the 20% - Accent4 cell style, name it Income&Expenses, and change the fill color to the lightest orange color.
Close the dialog box and apply the new custom cell style to cell A1. Then modify the new style and change the font size to 16 pt.
3. If you are duplicating a style, type a *new name* for the style in the **Style name text box**.

   Next, select the types of formatting items you want the style to include.

4. Select the options you want to use in the “Style includes” area.

   Now select formatting options.

5. Click the **Format button** and change formatting items on each tab, as desired. Click **OK**. Click **OK** again.

**Create a new cell style**

1. Click the **Home tab** and click the **Cell Styles button** in the **Styles group**.

2. Select **New Cell Style**.

3. Type a *new name* for the style in the **Style name text box**, if desired.

4. Checkmark or uncheck “**Style includes**” boxes to select which formatting items you want the style to include.

5. Click the **Format button** and change formatting items on each tab, as desired.

6. Click the **OK button**. Click the **OK button** again.

**Tips**

✓ Cell styles are associated with the theme that is being used for the workbook. If you switch to a new theme, the cell styles will update to match it.

✓ If you have another workbook that contains styles that you want to copy into the current workbook, click the **Cell Styles** button in the Styles group and select **Merge Styles**.
Using Document Themes

A **Document theme** is a set of unified design elements that you can apply to a worksheet to give it a consistent look and feel. Document themes coordinate the look of a worksheet with theme colors, theme fonts, and theme effects.

- **Theme Colors**: A set of eight coordinated colors used in formatting text and objects in the worksheet.
- **Theme Fonts**: A set of coordinated heading and body font types.
- **Theme Effects**: A set of coordinated formatting properties for shapes and objects in the document.

**Apply a document theme**

Applying a document theme affects all elements of the worksheet: colors, fonts, and effects.

1. Click the **Page Layout tab** on the **Ribbon**. Click the **Themes button** located in the **Themes group**.

   A list of built-in document themes appears. The default theme is “Office.”

   ✔ **Tip**: You may browse for additional themes online by clicking **More Themes on Microsoft Office Online**. Or, if a theme is saved elsewhere on your computer or network location, click **Browse for Themes** to go to the theme’s location.

2. Click the **document theme** you want to apply.

   The formatting associated with the selected document theme is applied to the worksheet.

**Customize a document theme**

You are not bound to keep the colors, fonts, or effects that are assigned to a document theme. You may mix and match theme colors, theme fonts, and theme effects.

1. Click the **Page Layout tab** on the **Ribbon**.

2. Click the **Theme Colors, Theme Fonts**, or **Theme Effects button** and select the set of colors, fonts, or effects you want to use.

   The change is applied to the document. The document theme isn’t changed; however, it is just no longer applied. If you want to use this custom set of themes again later, you’ll have to save them as a new document theme.

---

**Exercise**

- **Exercise File**: Sales and Expenses
- **Exercise**: Apply the **Apex theme**.

   Click the **Theme Colors button**. Select **Create New Theme Colors**. Click the **Accent 1 button** and change the color to **yellow**. Click the **Accent 6 button** and change the color to **red**. Click in the Name box and type: **Income&Expenses**. Click the **Save button**.

   Click the **Theme Font button**. Select **Create New Theme Fonts**. Changing the Heading font to Verdana and the body font to Bookman Old Style. Click in the Name box and type: **Income&Expenses**. Click the **Save button**.

   Save the current settings as a **new document theme** called **Income&Expenses**. Then change the worksheet back to the **Office document theme**.

---

**Figure 2-10**: Selecting a document theme.
Create new theme colors and fonts

You can also change which colors or fonts make up the theme colors and theme fonts. This can be useful if you want to create a document theme that is customized for your company or for a special project.

1. Click the Page Layout tab on the Ribbon.
2. Click the Theme Colors or Theme Fonts button.
3. Select Create New Theme Colors or Create New Theme Fonts from the list.
   A dialog box appears where you can select colors or fonts.
4. Select the colors or fonts you want to use.
   Once the color or font theme looks the way you want it to, save it.
5. Type a name for the new theme in the “Name” text box.
   If you want to coordinate new theme colors and fonts, save them under the same name, just as they are with built-in themes.
6. Click Save.

Save a new document theme

Finally, you can save any combination of theme colors, theme fonts, and theme effects as a new document theme.

1. Apply the colors, fonts, and effects you want to use in the new document theme.
2. Click the Page Layout tab on the Ribbon and click the Themes button in the Themes group.
3. Select Save Current Theme.
   The Save Current Theme dialog box appears.
4. Type a name for the theme in the File name box and click Save.

Tips

✓ When you save a new theme color or font, or save a new document theme, it becomes available in all Office programs.
✓ To remove a document theme or theme element, right-click the theme and select Edit. Click Delete in the dialog box and click Yes to confirm the deletion. You can’t delete Excel’s built-in themes.
Applying Conditional Formatting

With conditional formatting, you can apply cell formatting that varies based on the contents of the cells; the cells’ appearances change based on whether or not a specified condition is true for each cell. Conditional formatting allows you to emphasize particular values by making the data more visual—using highlights, data bars, colors, or icons.

Apply Highlight Cells Rules and Top/Bottom Rules

You can highlight specific cells in a range using a comparison operator; only cells that meet the specified criteria will be formatted. For example, you can highlight cells with values that are greater than a certain value, or cells containing values at the top or bottom of a range.

1. Select the cell range you want to format.

2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.

3. Point to Highlight Cells Rules or Top/Bottom Rules.

   A menu appears.

   Here you have several conditional formatting rules to choose from:

   **Highlight Cells Rules:** Greater Than, Less Than, Between, Equal To, Text That Contains, A Date Occurring, Duplicate Values.

   **Top/Bottom Rules:** Top N Items, Top N %, Bottom N Items, Bottom N %, Above Average, Below Average.

4. Select a conditional formatting rule.

   A dialog box appears, allowing you to specify the details relating to the rule.

   For example, if you selected the Greater Than rule, in the “Format cells that are GREATER THAN:” box you can enter a value or click a cell to enter a cell reference. Then you can click the list arrow and select the formatting you want to apply to cells that fit the criteria you set—in this example, cells that are greater than the value you entered.

5. Complete the dialog box options, as desired.

6. Click OK.

   The conditional formatting is applied to the cells.

Exercise

- **Exercise File:** Sales4-9.xlsx
- **Exercise:** Select the B4:G4 cell range. Click the Conditional Formatting button and the Top/Bottom Rules option. Select Below average. Click OK.

   Select the B10:G10 cell range. Click the Conditional Formatting button and the Top/Bottom Rules option. Select Data Bars and add the Blue data bars to cells.

   Select the B12:G12 cell range. Click the Conditional Formatting button and the Icon Sets option. Add the 3 Arrows icon set to (you may need to widen a few of the columns so that the arrow icons fit).

Figure 2-11: This list of options appears when you click the Conditional Formatting button in the Styles group.
Apply Data Bars, Color Scales and Icon Sets

You can also format cells with data bars, color scales, or icon sets to visually display variations in the values of cells in a range.

1. Select the cell range you want to format.

2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.

   Let’s take a closer look at three similar types of conditional formatting:

   **Data Bars**: Colored bars appear in the cells. The longer the bar, the higher the value in that cell. You can choose from different bar colors.

   **Color Scales**: Cells are shaded different color gradients depending on the relative value of each cell compared to the other cells in the range. You can choose from different colors.

   **Icon Sets**: Different shaped or colored icons appear in cells, based on each cell’s value. You can choose from several types and colors of icons.

3. Point to Data Bars, Color Scales or Icon Sets.

   A menu appears, differing based on your selection.

4. Select a data bar, 2- or 3-color scale, or icon set.

   The conditional formatting is applied to the cells.
Creating and Managing Conditional Formatting Rules

You can create and manage new conditional formatting rules that follow the parameters and formatting you specify.

Create a new rule

1. Select the cell range you want to format with a customized rule.
2. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.
3. Click New Rule.
   The New Formatting Rule dialog box appears.
4. Click a rule type in the Select a Rule Type list.
5. Complete the fields in the Edit the Rule Description area.
   This area will display different fields depending on the type of rule you selected.
   Tip: Click Preview in the New Formatting Rule dialog box if you want to see how the rule will appear before you apply it.
6. Click OK.
   The formatting is applied.

Other Ways to Create a New Rule:
Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group. Click Manage Rules, then click New Rule. Or, click the Home tab on the Ribbon and click the Conditional Formatting list arrow in the Styles group. Click one of the rule types, then click More Rules.

Manage rules

You can manage all aspects of conditional formatting—creating, editing, and deleting rules—in one place using the Rules Manager.

1. Click the Home tab on the Ribbon and click the Conditional Formatting button in the Styles group.
2. Click Manage Rules.
   The Conditional Formatting Rules Manager dialog box appears.

Exercise

- Exercise File: Sales4-10.xlsx
- Exercise: Select the cell range B4:G4, then create and apply a new formatting rule to apply bold formatting to values that are below average for the selected range.
  Select cells B12:G12 and edit the rule so that the green icon appears for values greater than or equal to 60% and the yellow for values greater than or equal to 30%.
  View the worksheet with the changes, then clear all the rules on the worksheet using the Clear Rules command.
3. Click the **Show formatting rules for** list arrow and select **This Worksheet**.

   All the rules applied to the worksheet appear in the dialog box. You can see which formats have been applied and which cells they have been applied to. You can use the New rule, Edit rule, and Delete rule buttons to manage the rules as you desire.

**Clear rules**

The Clear Rules command helps you remove conditional formatting rules from your worksheet.

1. Click the **Home** tab on the Ribbon and click the **Conditional Formatting** list arrow in the Styles group.

   If you want to clear only a selection of cells, first select the cell range.

2. Point to **Clear Rules**.

3. Select **Selected Cells** or **Entire Sheet**.

   Conditional formatting is cleared either from the cells you’ve selected or the entire worksheet.
Finding and Replacing Formatting

Excel’s Find and Replace features can find and/or replace formatting in addition to text and information.

1. Click the Home tab on the Ribbon and click the Find & Select button in the Editing group.

2. Select Replace.

   The Find and Replace dialog box appears, displaying the Replace tab.

3. Click the Options button.

   The dialog box expands.

4. Click the top Format button.

   The Find Format dialog box appears.

5. Select the formatting options you want to find, then click OK.

6. Click the bottom Format button, specify the new formatting options and click OK.

7. Click Find Next to find each occurrence of the cell formatting and click Replace to replace the cell formatting in each instance.

   After you replace an occurrence, Excel automatically moves to the next occurrence, so you only need to click Find Next if you want to skip an occurrence without replacing the formatting.

**Tips**

✓ Click Replace All to replace all occurrences of the cell formatting at once.

✓ To find other types of items, click the Find & Select button and then select one of the Find options: Formulas, Comments, Conditional Formatting, Constants, or Data Validation.

---

**Exercise**

- **Exercise File:** Sales4-11.xlsx
- **Exercise:** Replace all bold formatting in the worksheet with bold italic.
Microsoft Office Excel 2007: Level 2 Review

Quiz Questions

1. To copy cells using the mouse, press and hold the _____ key while clicking and dragging the selection.
   A. Alt
   B. Ctrl
   C. Shift
   D. F4

2. The Office Clipboard is available in other Office programs besides Excel. (True or False?)

3. With the Paste Special command, you can choose to paste only _______.
   A. values
   B. formulas
   C. cell comments
   D. All of these are correct.

4. Which button should you click to leave misspelled text alone and move to the next questionable word?
   A. Ignore Once
   B. Ignore All
   C. Add to Dictionary
   D. Change

5. When you insert a row, the existing rows are shifted in which direction?
   A. Left
   B. Upward
   C. Downward
   D. Right

6. Pressing the Delete key deletes the selected cell and its contents. (True or False?)

7. To access the find and replace commands, click the Find & Select button in the _______ group on the Home tab.
   A. Editing
   B. Cells
   C. Number
   D. Clipboard

8. You can delete a cell comment, but you can’t edit one. (True or False?)

9. Which of the following is NOT a type of font formatting?
   A. Bold
   B. Italic
   C. Underline
   D. Comma Style

10. Which of the following is NOT a type of number formatting?
    A. Number
    B. Accounting
    C. Dollar
    D. Percentage

11. You can align cell contents horizontally but not vertically within a cell. (True or False?)

12. The Border list arrow is located in the _______ group on the Home tab.
    A. Alignment
    B. Clipboard
    C. Font
    D. Number

13. Click the Format Painter button once to apply it once or twice to apply it multiple times. (True or False?)

14. Excel contains preset formatting styles that you can quickly apply to cells. (True or False?)

15. Document themes consist of:
    A. Theme colors
    B. Theme fonts
    C. Theme effects
    D. All of these

16. _______ allows you to highlight cells that meet specific criteria.
A. Conditional formatting  
B. Font formatting  
C. Filtering  
D. Find and replace

17. Which of the following is not a conditional format that can be applied to cells?  
A. Data Bars  
B. Characters  
C. Color Scales  
D. Icon Sets

18. You can preview how a new conditional formatting rule looks before you apply it. (True or False?)

19. You cannot edit a conditional formatting rule after you’ve created it. (True or False?)

20. Which of the following types of items can NOT be found using Excel’s Find feature?  
A. Formulas  
B. Comments  
C. Conditional Formatting  
D. Styles

Quiz Answers

1. B. Press and hold the Ctrl key to copy cells using the mouse.

2. True. The Office Clipboard can be used in all Office programs.

3. D. You can use the Paste Special command to paste any of these elements.

4. A. Click the Ignore Once button to leave text alone and move to the next questionable word.

5. C. The existing rows are shifted downward when you insert a row.

6. False. Pressing the Delete key only deletes the cell’s contents.

7. A. Editing

8. False. You can edit or delete a cell comment.
# Index

## A
- alignment
  - cells 22
- AutoCorrect 10

## B
- background color
  - adding to cells 24
- background patterns
  - adding to cells 24
- borders
  - adding cell borders 23

## C
- cell borders
  - adding 23
- cell comments
  - deleting 16
  - editing 16
  - inserting 16
  - viewing 16
- cells
  - adding a background pattern 24
  - adding background color 24
  - alignment 22
  - copying 5
  - creating a new cell style 27
  - cutting 5
  - deleting 13
  - formatting 20, 21
  - inserting 12
  - moving and copying using the mouse 7
  - pasting 5
  - styles 26
- check spelling 10
- Clipboard 8
- columns
  - deleting 13
  - inserting 12
- conditional formatting
  - applying 30
  - creating rules 32
  - managing rules 32
- copy formatting
  - with Format Painter tool 25
- copying
  - cells 5
- cutting
  - cells 5

## D
- deleting
  - cells 13

## E
- cells
  - formatting 20, 21

## F
- fill color
  - add to cell 24
- find
  - formatting 34
  - find feature 14
- Format Painter tool
  - formatting 25
  - copying with Format Painter tool 25
  - finding and replacing 34
  - labels 20
  - values 21

## I
- inserting
  - cells 12
  - columns 12
  - rows 12

## L
- labels
  - formatting 20

## O
- Office Clipboard 8

## P
- Paste Options Smart Tag 9
- Paste Special command 9
- pasting
  - cells 5
  - Paste Options Smart Tag 9
  - using the Paste Special command 9

## R
- replace
  - formatting 34
  - replace feature 14
  - rows
  - deleting 13
  - inserting 12

## S
- spelling
  - AutoCorrect 10
  - check spelling 10
  - styles
<table>
<thead>
<tr>
<th></th>
<th>Page</th>
<th></th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>applying to cells</td>
<td>26</td>
<td>creating new</td>
<td>29</td>
</tr>
<tr>
<td>creating a new cell style</td>
<td>27</td>
<td>theme effects</td>
<td>28</td>
</tr>
<tr>
<td>modifying or duplicating a cell style</td>
<td>26</td>
<td>theme fonts</td>
<td>28</td>
</tr>
<tr>
<td>removing from cells</td>
<td>26</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>theme colors</td>
<td>28</td>
<td>values</td>
<td>21</td>
</tr>
<tr>
<td>theme colors and fonts</td>
<td></td>
<td>formatting</td>
<td></td>
</tr>
</tbody>
</table>